Update dependency node-sass to v5 #36

Merged
samuel-p merged 1 commits from renovate/node-sass-5.x into develop 2 months ago
Collaborator

This PR contains the following updates:

Package Type Update Change
node-sass devDependencies major ^4.14.1 -> ^5.0.0

Release Notes

sass/node-sass

v5.0.0

Compare Source

Breaking changes
Features
  • Add support for Node 15
  • New node-gyp version that supports building with Python 3
Community
Fixes

Supported Environments

OS Architecture Node
Windows x86 & x64 10, 12, 14, 15
OSX x64 10, 12, 14, 15
Linux* x64 10, 12, 14, 15
Alpine Linux x64 10, 12, 14, 15
FreeBSD i386 amd64 10, 12, 13

*Linux support refers to major distributions like Ubuntu, and Debian


Renovate configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

♻️ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR has been generated by Renovate Bot.

This PR contains the following updates: | Package | Type | Update | Change | |---|---|---|---| | [node-sass](https://github.com/sass/node-sass) | devDependencies | major | [`^4.14.1` -> `^5.0.0`](https://renovatebot.com/diffs/npm/node-sass/4.14.1/5.0.0) | --- ### Release Notes <details> <summary>sass/node-sass</summary> ### [`v5.0.0`](https://github.com/sass/node-sass/releases/v5.0.0) [Compare Source](https://github.com/sass/node-sass/compare/v4.14.1...v5.0.0) ##### Breaking changes - Only support LTS and current Node versions ([@&#8203;nschonni](https://github.com/nschonni)) - Remove deprecated process.sass API ([@&#8203;xzyfer](https://github.com/xzyfer), [#&#8203;2986](https://github.com/sass/node-sass/issues/2986)) ##### Features - Add support for Node 15 - New node-gyp version that supports building with Python 3 ##### Community - More inclusive documentation ([@&#8203;rgeerts](https://github.com/rgeerts), [#&#8203;2944](https://github.com/sass/node-sass/issues/2944)) - Enabled dependabot ([@&#8203;nschonni](https://github.com/nschonni)) - Improve release automation ([@&#8203;nschonni](https://github.com/nschonni)) ##### Fixes - Bumped many dependencies ([@&#8203;nschonni](https://github.com/nschonni)) #### Supported Environments | OS | Architecture | Node | | ------------ | ------------ | -------------- | | Windows | x86 & x64 | 10, 12, 14, 15 | | OSX | x64 | 10, 12, 14, 15 | | Linux\* | x64 | 10, 12, 14, 15 | | Alpine Linux | x64 | 10, 12, 14, 15 | | FreeBSD | i386 amd64 | 10, 12, 13 | \*Linux support refers to major distributions like Ubuntu, and Debian </details> --- ### Renovate configuration 📅 **Schedule**: At any time (no schedule defined). 🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied. ♻️ **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox. 🔕 **Ignore**: Close this PR and you won't be reminded about this update again. --- - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box --- This PR has been generated by [Renovate Bot](https://github.com/renovatebot/renovate).
renovate-bot added 1 commit 2 months ago
80a4078073 Update dependency node-sass to v5
samuel-p was assigned by renovate-bot 2 months ago
samuel-p merged commit 9018f4a6a5 into develop 2 months ago
continuous-integration/drone/pr Build is passing
continuous-integration/drone/push Build is passing
The pull request has been merged as 9018f4a6a5.
Sign in to join this conversation.
No reviewers
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This pull request currently doesn't have any dependencies.

Loading…
There is no content yet.